Form designer - grey button on ribbon

Nov 5, 2010 at 7:42 AM

Hi

I installed Form Designer successfully and i am logged in as administrator, but i cant click on "Design form" button on ribbon. It is there but i cant click on it. Why ?

Thanks for answers and this great extension

Coordinator
Nov 5, 2010 at 3:56 PM

Hi,

You need to configure the list with the valid content types, meaning one of the "Forms Designer Content Types" before you can customize it! Then, the ribbon button will become usable.

Best Regards

 

Nov 8, 2010 at 7:13 AM

Hmm, how do i know which content types are valid ? i tried it with "Sinlge line of text" and still not clickable.

 

thanks

Coordinator
Nov 9, 2010 at 4:38 PM

Hi,

I encourage you to have a look at the manual

http://sptoolbasket.codeplex.com/releases/view/21960#DownloadId=69328

describing how to use the Forms Designer for SharePoint 2007, the principle remains the same for 2010

Best Regards

 

Jan 17, 2011 at 5:50 AM
Edited Jan 17, 2011 at 6:13 AM

So - Does anyone actually have this tool working?

In top level sites I get a greyed out button.  (In very sure I have the most current version. - I've uninstalled/reinstalled heaps.

I do have the right Content Types activated for the list. I've followed the 2007 instructions by every interpretation I can think of.

When feature is activated and I display the List's List Tools - Internet Explorer (8) indicates: (This is without clicking greyed out button.)

Webpage error details:

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; GTB6.6; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.30618; .NET CLR 3.5.30729; .NET CLR 1.1.4322; InfoPath.3; .NET4.0C; .NET4.0E)
Timestamp: Mon, 17 Jan 2011 06:35:52 UTC
Message: The collection has not been initialized. It has not been requested or the request has not been executed. It may need to be explicitly requested.
Line: 5
Char: 62099
Code: 0
URI: http://nice-dev/ScriptResource.axd?d=I455MF-PhaYRciRwkK7S5b2JVRwMWwA_Jwxam4LY9ZZp7EawVSN4wd_l5DH-HLUSYCLN9kvliA9BWgAbeznlNjv9ZAn4aL2F8yMIe3YmUac1&t=ffffffffec2d9970

Deactivate the feature and the error message goes away.

Does anyone have it working on SPF or should I give up?

BTW - this would be a great extention if I could get it to work

Coordinator
Jan 19, 2011 at 5:02 PM

Hi,

It's fixed...I don't know how this problem could be uploaded but I was probably tired at the time I uploaded the solution. I've reuploaded an up to date solution & source code and everything should be ok now.

Best Regards

Aug 12, 2011 at 6:59 PM

I have experienced this as of 08/12/2011.  The content types are not present at any site level, the feature is not present at any site level and there is no Design Form button on the lists.  The feature does show as Deployed to the entire farm in SP2010 CA.  Quite troubling.